← Vulnerabilities

Broccoli2Shell

CVE-2026-111497

Brotli decoder memory corruption lets remote attackers run code or crash apps

The flaw is a buffer overflow in the Google Brotli decompression library: a crafted Brotli-compressed stream can make the decoder write outside a reserved memory area. A remote unauthenticated attacker could use this to expose memory contents, cause a denial of service, or execute arbitrary code. It affects Brotli versions 1.0.3 through 1.2.0, is on CISA's known-exploited list meaning attackers are using it, and fixed versions 1.0.10, 1.1.1, and 1.2.1 are available.

Google Brotli · Updated 28 Oct · From 1 of our story and the public records

Being exploitedYesAttackers are using it
CISA known exploitedListedAdded 27 Oct; US agencies must fix by 10 Nov
SeveritycriticalCVSS 9.2 of 10
FixAvailableFixed versions below

Am I affected?

If you run a version older than the fixed one for your line, yes.

Version lineFixed in
Brotli 1.21.2.1
Brotli 1.11.1.1
Brotli 1.01.0.10

What to do

  1. Update any Brotli libraries or binaries in the 1.0.3 to 1.2.0 range to 1.0.10, 1.1.1, or 1.2.1 depending on your release line.
  2. Apply emergency vendor patches for affected platforms, including Microsoft's out-of-band .NET updates and PHP's Windows security update.
  3. Check vendor advisories for Brotli-dependent products such as Palo Alto Networks and Cisco for their patched versions.
  4. Treat this as urgent because CISA added it to the known-exploited list and US federal agencies must fix it by 2026-11-10.

What happened

  1. 26 OctMicrosoft released out-of-band .NET security patches for the critical Brotli flaw.
  2. 26 OctBleepingComputer reported the vulnerability as 'HTTP2Shell' and said it triggered emergency patches.
  3. 26 OctPHP issued a second Windows security update in five days to fix the Brotli code execution flaw.
  4. 27 OctCISA added the vulnerability to its known-exploited catalog with a US federal agency fix deadline of 2026-11-10.
  5. 27 OctHelp Net Security reported that the Brotli bug reaches far beyond Node.js.
  6. 28 OctPalo Alto Networks published a portfolio status saying the impact on its products is critical.
  7. 28 OctThe Hacker News reported Brotli exploit traffic emerging alongside Adobe Commerce PolyShell attacks.

The record

CVEWhat it isSeverityCISA listedExploit chance, 30 days
CVE-2026-111497Out-of-Bounds Write in Google Brotli Decodercritical 9.227 Oct55%

The records

nodejs.org: advisory ↗CISA known-exploited catalog ↗CVE-2026-111497 on NVD ↗
Is anything you run affected?Members connect Zotpaper to their AI assistant. It checks your own project against every vulnerability on this page and the others we track, and says what to update.
How it works